How to Configuration RIPv2 | Class Less

My special thanks to Blogger and Visitors. If You like this, please help us to share:
Digg Technorati del.icio.us Stumbleupon
Bookmark and Share

RIPv1

Distance Vector | Dynamic Routing | RIPv2

CISCO as The algorithm creator of RIPv1 known that The service of RIPv1 has some weakness, example : we can't use class less in configuration RIPv1. SO The RIPv1 need to development and overcome it's problems. That development is RIP version 2. RIPv2 was designed for class less, and it is better than RIPv1. To configure RIPv2, you must know how to configure the RIPv1, RIPv2 configuration is different with RIPv1.


There are some additional commands for use RIPv2, so it can use less class:
  1. version 2: to select RIPv2

  2. no auto-summary: to overcome the confusion network

  3. passive-interface: to affirm that each IP interface that is used is different.
Our Scenario:
We need 3 routers and 3 Clients
  • PC Client 1 connected to fa0/0 using IP network 10.10.10.0/24

  • PC Client 2 connected to fa0/0 using IP network 10.30.10.0/24

  • PC Client 3 connected to fa0/0 using IP network 10.50.10.0/24

  • Serial2/0 of Router 1 connected to Serial3/0 of Router 2 using IP network 10.20.10.0/30

  • Serial2/0 of Router 2 connected to Serial3/0 of Router 3 using IP network 10.40.10.0/30



Configuration on PC Client
PC1PC2PC3
IP address : 10.10.10.2
Netmask : 255.255.255.0
Gateway : 10.10.10.1
IP address : 10.30.10.2
Netmask : 255.255.255.0
Gateway : 10.30.10.1
IP address : 10.50.10.2
Netmask : 255.255.255.0
Gateway : 10.50.10.1



Configuration on Router
Router 1
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface fa0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s2/0
R1(config-if)#ip address 10.20.10.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit


Register network on Router 1
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#passive-interface fa0/0
R1(config-router)#network 10.10.10.0
R1(config-router)#network 10.20.10.0
R1(config-router)#end




Router 2
Router>enable
Router#hostname R2
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface fa0/0
R2(config-if)#ip address 10.30.10.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s3/0
R2(config-if)#ip address 10.20.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
R2(config-if)#exit
R2(config)#interface s2/0
R2(config-if)#ip address 10.40.10.1 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit


Register network on Router 2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#passive-interface fa0/0
R2(config-router)#network 10.30.10.0
R2(config-router)#network 10.20.10.0
R2(config-router)#network 10.40.10.0
R2(config-router)#end



Router 3
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface fa0/0
R3(config-if)#ip address 10.50.10.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface s3/0
R3(config-if)#ip address 10.40.10.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit


Register network on Router
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#passive-interface fa0/0
R3(config-router)#network 10.50.10.0
R3(config-router)#network 10.40.10.0
R3(config-router)#end


To show configuration your RIPv2, please do this command:
R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.10.0/24 is directly connected, FastEthernet0/0
C 10.20.10.0/30 is directly connected, Serial2/0
R 10.30.10.0/30 [120/1] via 10.20.10.2, 00:00:12, Serial2/0
R 10.40.10.0/30 [120/1] via 10.20.10.2, 00:00:12, Serial2/0
R 10.50.10.0/24 [120/2] via 10.20.10.2, 00:00:12, Serial2/0
RI#


If you do step by step about configuration RIPv2, you have gotten a RIPv2 with 3 router. Please improve your skill using more than 3 router, We believe you can do it. Trust yourself!!

Comments :

3 comments to “How to Configuration RIPv2 | Class Less”
Dhemz said...
on 

hey jojo...I just brought my adsense back...now I can participate the "clicking ads" lol....so from now on...I will hit your ads....hehhe...hope you'll hit mine as well...thanks!

401notfound said...
on 

hmm new post...

good articel jo,n' this semester, we must grab good point^^

Mehwish said...
on 

Paid To Click and Alertpay Guide

http://bollywoodhot1.blogspot.com/

Bollywood Hot Actresses Wallpapers

http://bollywoodhot1.blogspot.com/

Post a Comment

 

Tolearnfree Tags

Translator

Follow

The Directories of Tolearnfree